Groundhog day - Web filter not working with profiles configured for a group -again?

Hi everyone!
I just learned of NethServer about two months ago and I have been working with it on and off during that time. It really is an incredible system and I want to thank all of you for your work on it!

I’m new around here, and I think possibly groups are not working on my system for web filtering.

I found the exact same problem I’m having - already fixed - right here:

Some data on my system:
NethServer release 7.3.1611

I have several users and one group. I can change the “Default” profile and this will effect all of the users as it should.

If I assign a user to a group though, and assign a filter only to that group it will not filter any more or any less than the Default profile. Meaning (to me) that it isn’t assigned to the group or that it doesn’t know that the user is part of a group.

If I assign the profile directly to the user it will filter it properly.

I checked for the fix that was brought up in that post and it looks like it was implemented on my system

This is what mine looks like:
src src_somegorupprofile {
unix group “somegroup”

As I’m typing this I found something odd…
This is from the ufdbguardd.log file:

2017-05-21 16:11:04 [14854] source “src_profilesomegroup” {
2017-05-21 16:11:04 [14854] user
2017-05-21 16:11:04 [14854] user
2017-05-21 16:11:04 [14854] }

So it looks to me like it dumps the users from the group but does not remove the domain.

Looking further down in the ufdbguardd.log file at what it does when I only assign one user to the profile (rather than a group):

2017-05-21 16:11:58 [15324]
2017-05-21 16:11:58 [15324] source “src_profilesomegroup” {
2017-05-21 16:11:58 [15324] user alyssa
2017-05-21 16:11:58 [15324] }

It did remove the domain and it filters everything properly.

I think this is a bug, but if I just messed something up - I’d love to get help with fixing it! :slight_smile:

Thanks a lot for your help!

What do you think @filippo_carletti?

Indeed the same problem is back. I reported this bug back in January.

It seems there is a regression with nethserver-squid or nethserver-squidguard.

Hi Renen thanks for your post and compliments.
I’d like to involve also @davide_marini and @giacomo any clue on this problem?

I can confirm the misbehavior, it’s due to this change:

It’s the third time I have to fix web filter for groups :frowning: It’s a pain, I propose to drop feature! :smiling_imp:


Original issue


Opened a new issue:

The fix is out, would you like to test it @renen?
Just execute:

yum --enablerepo=nethserver-testing update nethserver-squidguard

Thanks for the bug hunting and thanks to @alefattorini to point me to this topic :wink:


Is working for me now. Thank you.


Hello, so I ran the yum command to test it.
I was able to add a group and the profile for the group but then after I applied the changes I can’t access the (nethserver):980/en-US/ContentFilter. The page says:

404 - Not found


Did I do something wrong or did something change?

I guess so :stuck_out_tongue:

This behavior is quite strange, check the messages log.
You can also try to reinstall:

yum --enablerepo=nethserver-testing reinstall nethserver-squidguard

My apologies @renen you didn’t nothing wrong, you hit a bug (but I can’t figure out how to reproduce).

Try the new rpm:

yum --enablerepo=nethserver-testing  clean all
yum --enablerepo=nethserver-testing update nethserver-squidguard

It should do the job. Let me know!

1 Like

It works!!!
Thank you everyone! The groups setting works.