Give system-user (passwd) access to shared folder

Hi all,

today my new hardware arrived, so finally I installed NS7 RC1 on real bare metal!:slight_smile:
I installed with Samba AD because I wanted authenticated shared folders. One of them contains my music-files (mp3).
It’s in a folder owned bij an AD-group ‘fileowner’ and in the ACL my children have read-access (no write).
I’ve installed squeezeboxserver ( instructions ). This creates a system-user " squeezeboxserver " in /etc/passwd.
However, this user isn’t allowed to read the shared folder:

root@helium> $ ls -l /var/lib/nethserver/ibay/
drwxrws—+ 319 fileowner@mydomain 12288 Oct 26 16:22 mp3

How can I add read permissions to the user squeezeboxserver?

I think what you need to do, is add squeezeboxserver via the Users/Groups GUI so that it’s an NS id. That way it can be added to your fileowner group.

At least that’s what I did in NS 6 for my plex system.


1 Like

If you use AD, passwd is useless

I’m new to samba NS, but your solution would result in 2 users ‘squeezeboxserver’: one in samba, and one in passwd. Can’t imagine that will work…

I’ve tried adding the local user to the group:
usermod -a -G fileowner@rolfbakker squeezeboxserver
but that doesn’t work either…

Any other ideas?

Sorry if I wasn’t clear. You only have the user defined to NS, not both.


then I have to let the sqb-server run as the NS-user ‘squeezeboxserver’ and change permissions on all server/programfiles to this NS-user. Guess that’s a shift of the problem that doesn’t make it smaller…

For now I found out that the checkbox ‘allow read-access to all users’ refers to the passwd-users (too?). Apparently it does a simple chmod +r on these files.
Not exactly what I wanted, but for now this will do.