File server Cockpit UI

Giacomo, Edoardo and I are working on the new File server application for the Cockpit based UI.

It is basically a porting of the existing Nethgui features to Cockpit, but more is coming:

  • Dashboard based on Samba status information
  • Integrated Samba audit UI
  • Shared folder space usage (from the Duc cache file?)

As announced in another topic, user, group, and shared folder quota could be available in the future with XFS filesystem.

See also

What do you think?


4 posts were split to a new topic: Samba audit tweaks

This is the current result:


User quotas are here shown or set in any way?

User/group/folder quotas are a proposal discussed in another thread. They are not implemented here.

Everything is in testing, but we need your help for the QA and eventually improve the labels!

@dz00te can you ping some one? :smiley:

1 Like

I’d like to do some testing, but I don’t get the right version.

I’m on 0.6.0-1.21.g4972612.ns7 from nethserver-testing, but no file-server-gui in cockpit.

Which repo to use?

The package is this one.

To install:

yum --enablerepo=nethserver-testing install nethserver-cockpit\* nethserver-samba

In the meanwhile Davide and Edoardo are doing some little fixes. :wink:




so is this the way to install with the release, or it will be available by default in nethserver.

Coooooollll. :smile:

I like it!
Sambastatus is great. Created some folders with and without ACL. Worked so far.


Since today the file server cockpit UI is available with normal update procedures (ie software center, yum update…)


Hello Davide,

can you please check the following:
I installed nethserver-samba with nethserver-cockpit today. After installation I could not reate a shared folder.
I found, that the files “create” and “delete” in /usr/libexec/nethserver/api/nethserver-samba/sharedfolders/ had wrong permissions. They were not executable.

-rw-r--r-- 1 root root 1721 May 28 17:35 create
-rw-r--r-- 1 root root 1649 May 28 17:35 delete
-rwxr-xr-x 1 root root 3905 May 28 17:35 read
-rwxr-xr-x 1 root root 1972 May 28 17:35 update
-rwxr-xr-x 1 root root 3314 May 28 17:35 validate

I made them executable, and it worked to create and to delete shared folders.
Is there a bug in the rpm?


Thanks for the heads up! I just uploaded a new RPM to testing, please check it out:

 yum --enablerepo=nethserver-testing update nethserver-samba

Did it. Installed package: nethserver-samba-4.3.0-1.1.gcb387d8.ns7.noarch

Changed executable back before updating. Than updated to above package and checked the files.
All files in /usr/libexec/nethserver/api/nethserver-samba/sharedfolders are executable.

Create and delete shared folders is working.

Thanks for fixing it! :+1:


The fix is now available from updates as

1 Like

2 posts were split to a new topic: Cockpit file server: InheritOwner option value is ignored