Failed to start NethServer Domain Controller container

NethServer Version: 7.6.1810 (final)
Module: nsdc

Today I couldn’t login to Nextcloud service, so I checked our Nethserver and found

‘kernel: IPv4: martian source from, on dev bond0
kernel: ll header: 00000000: ff ff ff ff ff ff 00 1e 67 11 73 71 08 06 …g.sq…’

in /var/log/messages. is the NSDC interface and is the main bonded interface.

I tried to restart the nsdc service but it failed.

In the same logs I found:

'Failed to start NethServer Domain Controller container.`

The server was working well on Friday… Can you help me to investigate further if it’s a hardware problem or a problem with the virtual machine that holds the NSDC?



NethServer as been rebooted from friday to today?
Did kernel version changed?
Which is the output of uname -r ?
Were changed something about ip address or Subnet?
Is address available currently?

Yes, have rebooted after the problem but it didn’t help.



Nope, same IP’s and subnet.

I had the same idea, but no NIC answers to a ping to that IP.

Is it possible to check the NSDC container for errors?

Maybe you can find some hints with

systemctl status sssd
systemctl status nsdc
journalctl -M nsdc -xe

And it looks similar to this problem:

Solved: it was a faulty NIC at the linked to the br0 interface.

ifconfig showed up a linked interface but when I managed to get to the datacenter it didn’t had lights turned on.

I replaced it and everything is working now. Ufff!

Thaks a lot for your answers,



Looking backwards… Messages were giving us an hint…
kernel: IPv4: martian source from, on dev bond0

Just a question: was the NIC part of bond0 ?

No it wasn’t part of the bond, the bridge was over it which I suppose NSDC used.