Failed to set ACL permission on new shared folder

v6.8
sharedfolders

#1

NethServer Version: 6.8
Module: shared folder

To expand the storage space I’ve installed 2 new disks in the server. I’ve created a new raid array (md3) and formatted it. Then I copied the shared folder “docs” to the new disk mounted on /mnt/md3/. Tu use it i’ve done a symbolic link in /var/lib/nethserver/ibay/docs to -> /mnt/md3/ibay/docs. The shared folder work with no problem.
Now i have a problem setting the ACL permission.
I have to set an ACL permission to permit at the apache service to write on this directory.

I’ve used the command:
setfacl -P -R -m u:apache:rwX,d:u:apache:rwX /mnt/md3/ibay/condivisa
but result in no acl permission set.

Output of getfacl:

root@summeet ~]# getfacl /mnt/md3/ibay/docs/
getfacl: Removing leading '/' from absolute path names
# file: mnt/md3/ibay/docs/
# owner: admin
# group: gruppo_doc
# flags: -s-
user::rwx
group::rwx
other::---

No change in acl permission.

Any idea of why this happens?


(Giacomo Sanchietti) #2

The filesystem of the new disk must support the ACL and mounted accordingly.
Please see http://docs.nethserver.org/en/v7/shared_folder.html#requirements


#3

File system is ext4
What means mounted accordingly ?

I’ve add a line in fstab

/dev/md3 /mnt/md3 ext4 defaults,acl 0 0

May be it was not mounted with acl ?


#4

I’ve remounted the file system with the acl option and now is working fine.
On boot the option acl was not loaded.