Errors on modules installation


(Gabriel GHEORGHIU) #1

System version: NethServer 6.7 - final
Kernel release: 2.6.32-573.el6.x86_64

The goal: Email server for multiple (different) domains placed in DMZ.

Note:

  1. On the same machine, with the same ISO DVD, installed three weeks ago (or more): no errors.

I have installed twice today (from scratch) with the same errors, following these steps (always), after first boot and settings:

  1. Set the Organization contacts;
  2. Set the New Server Certificate;
  3. First updates;
  4. Install the modules …

Today, at the first installation of NS, after the error, I have removed the POP3 Connector from Software Center and I have added again. The service for fetchmail was still stopped.

Some advices?

TIA,
Gabriel


(Filippo Carletti) #2

Maybe fetchmail stopped without accounts configured is normal.
I don’t use fetchmail, I’ve checked on a vm, installed fetchmail and the services panel show stopped.

Then I removed with

rpm -e nethserver-fetchmail

The service no longer show fetchmail.
The httpd error need to be investigated, see /var/log/httpd/error_log.


(Gabriel GHEORGHIU) #3

Hi Filippo,

Thank you for your answer.

You are right.
I have created an account and the service appeared Running.
After I have deleted the account, the service appeared Stopped.

Me neither.

The log:


(Filippo Carletti) #4

It seems that there is a problem with the certificate, see the first lines of your log.
Please show:

config show pki

(Gabriel GHEORGHIU) #5

I seen that error.
Chronologically, I don’t understand. The certificate was generated before updates and before add modules, with no errors. Please see /var/log/messages.


(Filippo Carletti) #6

It’s hard to tell what happened.
Here’s my SSL http config:

# grep SSLCert /etc/httpd/conf.d/ssl.conf 
SSLCertificateChainFile /etc/pki/tls/certs/sub.class2.server.ca.pem
SSLCertificateFile /etc/pki/tls/certs/localhost.crt
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

Can we see yours?


Need assistance with setting up generic email accounts
(Gabriel GHEORGHIU) #7

It’s because of the chain file?


(Filippo Carletti) #8

No, I need that because of my commercial certificate.

Maybe cert creation failed. Do you see the right values in the Server certificate page?
You could try to re-create the cert with

/etc/e-smith/events/actions/nethserver-generate-certificate

(Gabriel GHEORGHIU) #9


(Filippo Carletti) #10

httpd-admin restarted succeffully, did it also solve the problem of hjttpd?


(Gabriel GHEORGHIU) #11

It’s enough “/sbin/service httpd restart”, or should I do something else?


(Filippo Carletti) #12

service restart is enough.


(Gabriel GHEORGHIU) #13

It seems to be OK.

But it’s strange because there was no errors with httpd before adding modules, neither after that. The only error was when the adding modules process was finished.

Anyway, thank you for your support!

Kind regards,
Gabriel

PS

Till now, I checked the email server for one domain:

  • Outlook 2013 -> POP3: OK; IMAP:OK
  • Thunderbird -> POP3: OK
  • Android phone -> IMAP: OK
  • Windows phone 8.1 -> IMAP: OK