Error with NextCloud integration in Webtop

webtop5
nextcloud

(Wayne Bilger) #1

I have tested this before and it worked, but just enabling on my production NS Server as below, and getting an error, no description, just a box pops up with a red X and “Error”. Can’t find anything in logs.
I have followed these instructions;
http://docs.nethserver.org/en/v7/webtop5.html#nextcloud-integration
I have tried with just leaving ‘localhost’ in the Host: location, and I have also tried my fqdn.
The issue may be that I set NextCloud virtual host to the root of my FQDN. So, nextcloud is reached at https://office.mydomain.com instead of /nextcloud, but I did update the default in the Properties with webtop admin. So the default location when adding the NextCloud resource in webtop is /remote.php/webdav/ (instead of /nextcloud/remote.php/webdav/)
I can login successfully to NC webdav with another webdav client at https://office.mydomain.com/remote.php/webdav/


(Markus Neuberger) #2

Yes, it works with another virtual host but not with the same virtualhost as the server name. I recommend using another subdomain like nextcloud.mydomain.com as Nextcloud virtual host.

This was not working for me when using the server FQDN as nextcloud virtualhost.


(Wayne Bilger) #3

That is what I want to use, well actually I just want to use the normal office.mydomain.com/nextcloud, but I want a landing point with the root of our domain, office.londonroofruss.com to be webtop, but I couldn’t figure out the redirect as I asked in this post, Root http https route to webtop
Any help with this would be appreciated!

So as a workaround the nextcloud virtualhost works, and then nextcloud allows you to add external links to point users to our other services. I guess I’ll have to get rid of that to get this working for now.