Error while updating nethserver and installing packages from software center

Hi Andi,

It seems that you don’t have internet connection or misconfiguration of DNS.

Kind regards,

1 Like

Hope check ur internet connection first it’s due to internet connection.
First let me know you are configuring with green or green and red interfaces

1 Like

are you behind a proxy?

1 Like

Well i got my dns from nm-tool command in my terminal, maybe is not the right command …
@saikrishnavedaraju i cant access the web-gui and my host pc has a working internet connection :confused:
@mabeleira no im not behind a proxy

Ill try to delete this virtual machine and create a new, fresh one, maybe that helps!

I think is misconfiguration between host pc and vm.
You need bridge between NICs.
I know that somewhere in this forum you will find how to configure NS as VM.

How is the network card configured in virtualbox?

Ok ill have a lookt at it right now!
@jgjimenezs this is the ifconfig in the virtual machine

I am installing a virtual machine - Video Tutorial.

Are you using as your virtualbox bridge network?

Try this:

  1. Use mode network bridge
  2. The NethServer gateway IP is the IP of your router
1 Like

Youre nethserver is a virtual machine? how are is the network adapter
configured? if you cant acces the gui? how you managed to print the
software management screen?

can you access the gateway from the virtual machine?

1 Like

I am in a bridge mode, wlan0 (as i am on a wifi connection) to be precise still noting …
@mabeleira yes im on a virtual machine, and i can access the gui i just cant install packages through “software center” option :confused:
nor yum update on the vm
And yes, i can ping on the vm !

try ping


I’m using the ip of my router as a gateway

1 Like

it shows :

ping : unknown host

Thank you!!!
On the network tab i changed the default gateway (that was to the router one
And now it works :smiley:
Thank you again :smile:

1 Like

you’re welcome @Andi_Domi

Good to know, @Andi_Domi you have to pay a :beer: to these guys @jgjimenezs @mabeleira @saikrishnavedaraju @GG_jr

Think that something like this might help in this cases:
How about a set of configuration tests?


Another case closed! Solved! :smile:


I believe i have to!
But im gonna ask them again so ill better give them a :beer: and a :pizza:
Thanks again guys :smile:


What about dns configuration? did you set your isp dns servers?