Error when trying to access Nextcloud on Webtop

Hello,

After a fresh install of Nethserver, I’m unable to access Nextcloud folders via Webtop. Concerning the environment, I currently have :

  • a full updated Nethserver (7.6, but also tried with 7.5 with no moe success)
  • Last version of Webtop available in NS repos
  • Nextcloud 15.0.5 (NS version, but I also tried with an external 15.0.7 with no more success)

When I try to access, I have a popup with just “Error” mentionned. Can someone tell me how I could have a more accurate description of this problem ?

Thanx,

Guillaume

Could you post screenshot of your configuration?

1 Like

Sure, but I don’t understand what you need :wink: A screenshot of the dashboard ? Or the WebTop config ? If you want I can even send you a full backup of the NS config, it’s just a test server currently

I need a screenshot of your Webtop Cloud when you try to access Nextcloud folders. All steps… :slight_smile:

1 Like

Hi @Phenex,
you have already checked that you have followed all the instructions in the documentation here: https://nethserver.docs.nethesis.it/en/master/webtop5.html#nextcloud-integration

In addition to the screenshots it could be very useful to read what is reported in the log (/var/log/webtop/webtop.log) when the error is shown on the interface, can you paste it here?

1 Like

OK…that doesn’t make any sense…I was doing the screenshots, so I deleted the current connection to recreate one…and now it works :smiley: and I tried this before, several times…do you have the magic hand (that’s what regular users says when me, the IT guy, arrives at their desk, and…tada…it works…now I know how they feel) ? :smiley:

I still have the problem when trying to connect to an external cloud, but it may be a firewall issue, so I will continue testing

Thanx anyway, I don’t know what strange vibes you sent, but it worked :wink:

1 Like

Well, the second problem seems to be related to my external Nextcloud instance, and the fact that Webtop uses Jakarta Commons HttpClient ? see this page for those who have the same problem :slight_smile:

I implement the solutions and it seems to work better (not perfect though, I can access my files but I sometimes need to click 2 times to get rid of the error)

@lucag @federico.ballarini I think I found the source of the problem, it seems to be related to files/folders with accents (in french) which are not correctly interpretated with the Nexcloud integration (I do not seem to have any problem with the internal Webtop document storage)

I know french is not currently integrated on Webtop 5 but I’m working on it, so it would be great if files/folders in french could be correctly displayed (don’t know if it’s a Nexcloud problem or a Webtop problem though)

I made a test with a folder named “testé” and here is what I found in the log :

org.apache.commons.vfs2.FileSystemException: Could not find files in “webdavs://guillaume:***@localhost/nextcloud/remote.php/webdav/testé”.
Caused by: org.apache.commons.vfs2.FileNotFolderException: Could not list the contents of “webdavs://guillaume:***@localhost/nextcloud/remote.php/webdav/testé” because it is not a folder.
org.apache.commons.vfs2.FileSystemException: Could not rename “webdavs://guillaume:***@localhost/nextcloud/remote.php/webdav/testé” to “webdavs://guillaume:***@localhost/nextcloud/remote.php/webdav/teste”.

1 Like