Enable two analog modems for the fax server?


NethServer Version: 7.5.1804
Module: Hylafax

I’ve got a Nethserver setup with two serial (RS232) external modems attached via serial ports (ttyS0 and ttyS1). I’m able to enable fax receiving through 1 of the modems at a time, currently ttyS0, and am able to receive faxes.

It looks like the GUI only enables a single instance of the faxgetty service, what is the best way to run an additional faxgetty for the second modem? Hylafax documentation mentions using inittab, however it seems that wouldn’t work since Nethserver uses systemd.

Simply running faxgetty ttyS1 in a terminal allows the second modem to start receiving faxes, however that only works as long as the terminal is open, and it would be nice to have something persist through reboots.

Any input would be appreciated!

I can’t test it but does it work using neth-addmodem or addfaxmodem on command line?



Or you may need some extra config in /etc/hylafax/hyla.conf…to make config changes permanent, use custom templates.


1 Like

I already used faxaddmodem to setup the second modem, (neth-addmodem doesn’t pull the correct config for the USR modem I have for some reason). After running faxaddmodem however, you need to setup an instance of faxgetty to listen for incoming faxes on that device.

Here is the documentation I’ve been working with:

To enable use of the configured modem one must either use the faxmodem(1m) program or configure the init(1m) program to startup a faxgetty(1m) process for the newly configured modem.

It seems you can just start another modem with

systemctl start hylafax-faxgetty@ttyS1

If you need it to start up at boot you may do

systemctl enable hylafax-faxgetty@ttyS1


Perfect! This is exactly what I was looking for. I’ll be trying this tonight and I’ll let you know how it goes!

That worked great, both modems are listening for faxes and it persists through reboots.

The only thing I would add is that I was getting corrupt tif files on some faxes, but the pdfs were fine. I did some digging around and added this line to the config file:

Class1JBIGSupport: no

Per: http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=730
I haven’t had a corrupt tif file since.



Could you mark the topic as solved please.