Download never ends & Word doesn't connect to OneDrive

NethServer Version:

Collectd Charts

Dynamic DNS
File server
Stephdl is online
Web server
Hello everyone…

Since I put the NS as a PPPOE dialer in the network, replacing the operator’s router, I’ve been noticing small problems.

  1. The downloads never end, reaching 99.99% and never end… ever…

erro download nethserver 99 02

  1. The other problem so far noticed is the office 365 which cannot access the onedrive to save or open documents saved on it. Sometimes staying for hours to give an answer, when I give an answer.
    erro onedrive x word 01

What do you need to know so that you can help me with these questions?

Say the commands I run and post here.
I’m kind of lost in all this…

NOTE: even before installing these third-party applications, I was already noticing these problems. When I put a router eliminating the NS, EVERYTHING BACK TO NORMAL.

I just discovered the reason for the errors reported above.

the IPS is blocking somehow…
It is noteworthy that I have NOT configured anything on the IPS. I just installed it and then set it up…

IPS settings can literally cut of any service available, if wrong.

Could you please try to change a setting in the IPS configuration file to check if it solves your problems?

Open /etc/suricata/suricata.yaml with a text editor, go to line 1373, add drop-invalid: no below stream: maintaining indentation (two spaces, like in memcap:).

Check that the setting is correct:

[root@ns7-ent ~]# suricata --dump-config | grep drop-invalid
stream.drop-invalid = no

Then systemctl restart suricata.

If you find problems, please, ask me, I’ll try to work on a patch easier to install.


I’ll leave testing for a while until I notice something strange again.

Thanks for the resolution…

two days without problems or BUGs…

Looks like the tip solved everything…

I’ll put it as resolved, and if any more inconveniences appear, I’ll come back here and reopen the post…