DEPRECATED! Package nethserver-xxxxxx must subscribe nethserver-sssd-save event explicitly


(Stéphane de Labrusse) #1

I found this in logs when I installed nethserver-directory after nethserver-dokuwiki

[WARNING] DEPRECATED! Package nethserver-dokuwiki must subscribe nethserver-sssd-save event explicitly

I only rely on nethserver-directory-update or nethserver-dc-update in the createlinks of my rpms when I need to expand the authentication templates.

I suppose I need to add nethserver-sssd-save, can I left the two event-update or I must keep it ?


(Davide Principi) #2

Yes and if a config file template uses NethServer::SSSD to reconfigure the direct access to LDAP it must subscribe nethserver-sssd-save to catch up with account provider config changes.


(Stéphane de Labrusse) #3

fixing my modules I thought that nethserver-sogo does not subscribe to nethserver-sssd-save event

it should no ??? @giacomo and @davidep

EDIT, the answer :stuck_out_tongue:

[WARNING] DEPRECATED! Package nethserver-sogo must subscribe nethserver-sssd-save event explicitly


(Marc) #4

@stephdl, nethserver-transmission has the same issue (#5600):

Aug 20 00:18:45 server esmith::event[5320]: [WARNING] DEPRECATED! Package nethserver-transmission must subscribe nethserver-sssd-save event explicitly

nethserver-madsonic and nethserver-nfs maybe too.


(Markus Neuberger) #5

I am afraid nethserver-guacamole is affected too.

Fix is coming soon…


(Stéphane de Labrusse) #6

Thank for the notifier


(Stéphane de Labrusse) #7

done tk