Database problem, creates base but no tables inside


(Jurica Korac) #1

NethServer Version: 7.4.1708
Module: Nextcloud, but basically any that needs db

This might be under Bug part of the community. I kindly ask moderators to move it there if needed.

We had an issue with database. Issue was that SOGo, Nextcloud and Roundcube did not work correctly. To be more precise:

  • SOGo crashed often: required restart of the service to work again,
  • Roundcube didn’t work: you couldn’t login and there was a notice indicating there is something wrong with database
  • Nextcloud: indicated there’s an Internal Server Error, but the logs were empty

We managed to fix SOGo and Roundcube problems, but Nextcloud did not.

Here’s the course of actions we did:

  1. Removed all three modules: after this step, uninstallation did not remove databases we had to do it manually
  2. Removed databases
  3. Re-installed all three modules: after this, SOGo and Roundcube worked, but Nextcloud didn’t (see below)

Nextcloud during the installation gave errors meaning when the process of installation finished there was a red label saying that task finished with some errors.
After that, when page refreshes, there’s a red label on top of the screen saying: Resolving RPM dependencies
The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation."
As we tried to do several takes to re-install Nextcloud, we also did try to clear cache before and after the installation process. But every time you click - or clear the cache by command - it ends up with Nextcloud already installed but not working. Which means we are at the beginning of this loop. It recreates database, but completely empty, with no tables inside!

Is there something we could do it to prevent this?

Cheers


(Michael Träumner) #2

Please try to uninstall it at command line

yum remove nethserver-nextcloud

clear yum cache

yum clean all

and reinstall nextcloud

yum install nethserver-nextcloud

If there are any errors please post them