Connect to console with putty and Certificate

Log into the Server using Putty with username and Password is no Problem, when I try to set up using a certifikate I get the error “Server refused our key”. Is there something special to set on Nethserver to use keys? On other Linux versions, also with openssl and putty there is no Prolem.
Using Nethserver latest version with all patches, putty 0.7

Hi @pnemenz,

I found this documentation and it worked, I could login with putty with username and ppk file.

Here is another one, ssh-copy-id - Making Pageant automatically load keys

1 Like

this is how I tried to do it, doesnt help, always get an error: Server refused our key

ok… so, please, tell us how did you configure your server to auth via key using putty
thank you

I added PubkeyAuthentication yes to /etc/ssh/sshd_config
just edited the fiel :blush:

well… it can’t work :slight_smile:

ˢᵒʳʳʸ ᶠᵒʳ ᵗʰᵉ ⁿᵉᶜʳᵒᵖᵒˢᵗ
Which file needs to have the pubkeyauthentication option added to make the change permanent? I have several automated tasks and would prefer to use key authentication.

Sorry I do not understand your question, can you try to rephrase?

In the current version of Nethserver, there are many template files.
Ex: /etc/e-smith/templates-custom/etc/dnsmasq.conf
Which of the template files should be adjusted to include the line pubkeyauthentication yes in order to allow key-based auth for sshd since there’s no selector in the web gui to activate this feature?

None of them; this is supported by default. There isn’t any facility I’m aware of in the GUI to import the public key, so you’d need to that at the CLI, but the stock config files allow public key authentication for SSH. The only option in the GUI is whether to require public key authentication, or whether to allow password authentication as well.



this works for me:
(Note the nethserver specific home directory for a (local LDAP/AD) user.)

$ pwd

$ ls .ssh/

$ cat .ssh/authorized_keys
ssh-rsa <long key>== 

for root ssh login it is business as usual

# pwd

# ls .ssh/

# cat .ssh/authorized_keys
ssh-rsa <long key>==

Hope this helps…