Conflict between WebTop and SoGo?

sogo
v7
webtop5

(Dan) #1

NethServer Version: 7.5
Module: sogo, webtop

As I’ve mentioned before, I mainly run my Neth box for my family. When I reasonably can, I like to give options. So there are five packages for Neth that do webmail: Roundcube, Rainloop, Horde, WebTop, and Sogo. Right now I have Roundcube and Horde installed, and will probably play with Rainloop shortly. I’d be glad to go ahead and install Sogo and WebTop as well, but I see that they both do ActiveSync. Is there going to be any conflict between these? Or can I have them both installed without causing any problems? Any gotchas I should be aware of?


(Giacomo Sanchietti) #2

You need to decide which service will provide the Active Sync protocol.

See http://docs.nethserver.org/en/v7/webtop5.html#webtop-vs-sogo


(Mark Verlinde) #3

yes you do, however when we (i) wrote the redirects web-top has preference…
Was never tested as webtop 5 was in full development back then…

  if ((($sogod{'ActiveSync'} || '') eq 'enabled') && (($webtop{'ActiveSync'} || 'disabled') eq 'disabled')){
     $OUT .= <<EOF

# Sogo ActiveSync is enabled

same for DAV

if ((($sogod{'Dav'} || '') eq 'enabled') && (($webtop{'Dav'} || 'disabled') eq 'disabled')){
          $OUT.= "RewriteRule ^/^(cal|card|dav)\$               https://%{HTTP_HOST}/SOGo/dav [R=301,L] \n";
          $OUT.= "RewriteRule ^/.well-known/^(caldav|carddav)\$ https://%{HTTP_HOST}/SOGo/dav [R=301,L] \n\n\n";
    
}

You could be the guinea-pig and test if it works? :roll_eyes::smirk:


(Dan) #4

I’m not personally interested in ActiveSync at all, as long as the one system doesn’t break the other. I guess I’ll try it with the defaults, and if something starts to look broken, probably disable ActiveSync in both apps.

BTW, there’s a bug on the WebTop doc page in the section where it tells you how to configure Google and Dropbox integration. It says (in two places) to run

su - postgres -c "psql webtop"

In reality, you need to run:

su - postgres -c "psql webtop5"

(Dan) #5

Well, I thought I’d install both, but SOGo doesn’t appear in the software center, and yum install nethserver-sogo doesn’t work either.


(Stéphane de Labrusse) #6

Sogo is in nethforge, check if the repo is enabled, you could also clean the cache


(Dan) #7

Does that mean it isn’t production-ready? Or only that I won’t get it (without manually enabling the nethforge repo) if I have a subscription on my server?


(Mark Verlinde) #8

@danb35 excuses for this hijack of your toppic
@giacomo as you noticed , i’ve got some time left, sorry for asking so much attention

looking at this

this

Above statement about {Card Cal}-dav is false, as WebTop5-webdav is not {dis en}abled with a e-smithdb-prop. Just sharing en insight here :grinning:

@webtop_team


(Giacomo Sanchietti) #9

Are you saying that SOGo implements the same configuration for WebDav?
I didn’t check it, to be honest.

@alefattorini could you add @Amygos to webtopm_team?


(Mark Verlinde) #10

Sogo treats (e-smith props) ActiveSync and Dav in the same manner.
IMHO it’s a nice feature be able to remove all rewrite rules to (what-ever) web-service; Just a matter of preference: close the most in front possible door.

EDIT:
Have to live up to my words here!


(Stéphane de Labrusse) #11

seems that the subscription broke something, normally nethforge is enabled per default since years, try to add it manually --enablerepo=nethforge

I ping here @davidep


(Rob Bosch) #12

Define “(not) production-ready”
I am running SOGo for about half year now on NethServer. (before that I ran SOGO2.x on Linuxschools) and it hasn’t failed me yet.
Although I must say, I barely use the web interface. Most use of my mailserver is through Thunderbird.


(Davide Principi) #13

Nethesis does not sell support for packages in NethForge, so #subscription installations do not have NethForge enabled by default.

@danb35 if you have #subscription and want to re-enable nethforge for SOGo refer to

http://docs.nethserver.org/en/v7/subscription.html


(Nitram Oneito) #14

EDIT: the issue seems to have been fixed

I am currently using sogo on a production environment, before setting up the environment I had staging environment for a bout two weeks, sogo and webtop did not do so well, I have multiple conflicts, which in some cases caused me to have to re-build the whole installation. so I would not install the two at the same time, if you have had luck let me know, I try again on one of my staging servers.


(Stéphane de Labrusse) #15

What kind of conflicts, can you detail them and provide logs please


(Nitram Oneito) #16

I will rebuild the server and replicate the process, then share what I was experiencing


(Alessio Fattorini) #17

Done, sorry for the late reply :slight_smile:


(Nitram Oneito) #18

as promised, I tried rebuilding the server and replicating the steps that I followed initially to see the erro, but its seems like there is an update that fixed the error.

Initially, I had tried more than three times with the same error.