Collabora Online in Nethserver-Nextcloud

How exactly are you doing this?

The command is docker cp containerID:/path/to/file/in/container /local/path
Don’t forget the “:” after containerID
The container ID you can find with: docker ps.
To open a shell in the docker container to find a file: docker exec -it containerID /bin/bash
AFAIK the certificates are in /etc/loolwsd in the container. Do you know if there are others?
Example: docker cp 52c20b531c45:/etc/loolwsd/ca-chain.cert.pem /root/ca-chain.cert.pem

Are you importing the certs every time you launch the container?

Good point. I’ve to say I didn’t notice that they were changing, but I tried it within the running time of the container. And checked it right now again. But the erreor still appears. :sob:
It’s time for weekend. Next attempt next week. :slight_smile:

When you get back on it, you could try appending the docker cert to the nextcloud ca-bundle.crt, aswell as your own NSRV.crt to it

something like

docker exec cat 52c20b531c45:/etc/loolwsd/ca-chain.cert.pem >> /var/www/html/nexcloud/resources/config/ca-bundle.crt

cat /etc/pki/tls/certs/NSRV.crt >> /var/www/html/nexcloud/resources/config/ca-bundle.crt

systemctl restart httpd.service

have a nice w/e!

Thanks for trying to help, but I allready did that without success.
PS apache.service on nethserver is httpd.service

I want to revive this topic so we can work on a solution for NS7.
I also installed collabora in a container, but had difficulties to get the path to nextcloud configured. Collabora instructions talk about a subdomain where nextcloud is hosted, but on a NS7 server, nextcloud runs on https://ns7server/nextcloud

There is clear video tutorial available, made by @jospoortvliet :

Found this:


Funny enough, I have been testing Collabora / Nextcloud with LetsEncrypt certifications (using Webmin to manage and update the certs. I also included the same certs into my IMAP and SMTP configuration).

Although I have no time to work on this for the time being, I will more than happy to help anyone wants to make some tests

Hi there,
I started again to work on this and solved the problem with the certificates, but now I’m facing another problem.

I can add a document, but when I try to open it, I get “service temporarely unavailable”.
In the http-error-log I find this:

[Fri Apr 21 11:56:27.743270 2017] [proxy_http:error] [pid 5797] (103)Software caused connection abort: [client] AH01102: error reading status line from remote server
[Fri Apr 21 11:56:27.743343 2017] [proxy:error] [pid 5797] [client] AH00898: Error reading from remote server returned by /hosting/discovery

I searched for the AH01102 and the AH000898 failure, but found nothing which helped me.
I checked the firewall, but it’s not blocking. AFAICS the docker interface is correctly implemented in shorewall.
interface: dock docker+ optional
policy: dock fw ACCEPT and fw dock ACCEPT
zones: dock ipv4

Has someone an idea??

TIA Ralf

Hi Ralf,
I’ve found something similar to yours at sophos forum. They say you have to do it with dnat.
Here is the link:
and something by serverfault, they do it in virtualhost config:

Hi there,
cool work- is probably the developer team thinking of intergrating that into nethserver- at the moment I’m looking for a google drive replacement- and that would be ideal?
Greetings from Vienna

Hi @iglqut , nice to have another austrian here.

If I’m honest, my skills are not sofisticated enough at the moment to solve this.
I’ll keep on working on it, but I don’t know when there’ll be a solution.

Don’t know if someone @dev_team is thinking to integrate this as a regular module.
Would be really great to have this as a module.

Greetings from the "Ländle"

1 Like

That’s exactly what I meant :wink: Just wishing

1 Like

I’d agree as well. And it seems that we could set up Nextcloud as a virtual host, so it’s at nextcloud.domain.tld.


AFAIK It requests a huge work of coding and testing, but no concrete analysis has been done so far.
I’d like to see this feature on NethServer too


That would be a game changer. That’s the last thing that keeps us to go switch to nextcloud : users can’t live without google docs.


I know that would be a game changer and I would definitely like integrate it.


I have managed to integrate Collabora / Nextcloud within my VPS using a minimum installation of Ubuntu and a docker session (I would generally not usually use Ubuntu, but due to issues surrounding my VPS provider, docker and kernel versions, Ubuntu was the most applicable option available to me at the time of installation).

I have been using this solution (within my VPS) for approximately a year and have yet to replicate this setup within a RPM based distribution (but have been able to duplicate this framework within a Debian based environment).