Cockpit OpenVPN and IPSec UI

Thanks for verifying Marc. :+1:


Thank you @flatspin and @dnutan for the amazing troubleshooting!

Thanks to the help from @davide_marini and @edoardo_spadoni, the latest package from testing (nethserver-vpn-ui-1.0.0-1.7.gd2be0b8.ns7.noarch.rpm) should fix the problems reported by @flatspin and @dnutan!


Will test it when back to work on friday.
TIA for your work. :+1:


I use openvpn roadwarrior primer on my Android device. and after I have tested the new Cockpit UI.
I can no longer get online, if I change in Digest and Cipher.

Even if I download a new openvpn file from the new UI, it failed to import it.
I get this error: Failed to parse profile: crypto_alg auto not found.
The version of openvpn for android is 3.0.5(1816)

1 Like

With the package from testing, the described issue with the save button is solved.

1 Like

That’s strange the “auto” keyword shouldn’t go into the ovpn config file. I will try to reproduce and fix it.

Confirm, that issue with save button seems to be solved. After pressing save:

Downloaded openvpn-config-file is correct with auth and cipher, choosen in vpn-ui and is working correctly on my system out of the box!

Thank you for your great work!


Thank you Michael, I reproduced the issue.

Everything should be fixes in latest package (nethserver-vpn.-ui.1.0.0-8-g59ed743) from testing.
Install the new packages, access the Roadwarrio server configurarion and click “Edit”.
Then download again the file and everything should work out of the box.

1 Like

I have just test the new uiUdklip1
And with these setting everything works:-)

so many thanks for the support