Chat app on Nextcloud 11 - Has anyone successfully set this up to use Nethserver Ejabber?

NethServer Version: NethServer release 7.3.1611 (Final)
Module: Chat Server (Ejabber)
Module: Nextcloud 11.0.2 (stable)

Hello Team,

Kicking at this again but this time from Nextcloud. I’ve installed the JavaScript XMPP Chat app on Nextcloud. I’d like to give our employees the ability to use this chat feature from Nextcloud as I’m moving more services to within Nextcloud (or at least test that ability). Has anyone successfully setup the Nextcloud chat app using Nethserver chat server? Here is what I need for setup:

I’ll need to use an External XMPP server I’m assuming.
Is my XMPP Domain. I’ve configured a domain in Nethserver. I’ll use that configured domain.
Where do I find my BOSH url?
There is reference to ICE Server and Screen Sharing under the JavaScript XMPP Client settings. I’m assuming I don’t need these filled out to use the chat app. But comments are welcome.

Thank you.

I just updated the doc:

You can also find the same information on

Thank you @giacomo for your quick response to my post. Sorry but I need further direction based on the documentation.

I’ve created a new group (manually created) called jabberadmins. I’ve added a user to this group and then logged into Nethserver with this user. Am I supposed to see more options in Nethserver for configuring Ejabber? Under Configuration > Chat Server all I see if the checkbox to enable Ejabber. I don’t see any reference to Welcome Subject, Welcome Text or XMPPAccess…where are these settings found?
In my Nextcloud I’m putting in my chat settings. My FQDN for my server is What do I put into Nextcloud javascript XMPP Client Basic settings for XMPP domain? Do I put in or the FQDN?
I entered the following in BOSH url: I have the following error when it checks my Bosh url:

BOSH server NOT reachable or misconfigured.

Cross domain request was not possible. Either your BOSH server does not send any Access-Control-Allow-Origin header or the content-security-policy (CSP) blocks your request. Starting from Owncloud 9.0 your CSP will be updated in any app which uses the appframework (e.g. files) after you save these settings and reload.The savest way is still to use Apache ProxyRequest or Nginx proxy_pass.

There are no other required fields in the Nextcloud chat server settings (nothing else besides the above two settings with an Asterix). What else needs to be put into these settings to get chat to work with Nethserver Ejabber?

Thank you.

Nothing else, it works out of the box (tested right now :wink: )


You must access the server from the same name used in the BOSH URL.


Ok @giacomo we’re getting closer. :slight_smile:

so what you are saying is for Nextcloud chat to work with my Nethserver Ejabber all I need to add to my Nextcloud Javascript Xmpp Client settings are the following two fields under Basic (External setup):

XMPP Domain -
BOSH url:

Is the above a correct statement?

My BOSH error has now changed to be the following error:

BOSH server NOT reachable or misconfigured.
502 Proxy Error

I hope this means I’m getting closer to having this work. What’s missing for me to get this error? Any ideas?

Thank you.

Almost :smiley:

These are the correct settings:

XMPP Domain -
BOSH url:

Hi @giacomo, my mistake. I had typed in that in manually for my post reply and missed the ‘.’. I’ve confimed that my nextcloud settings are the same as what you’ve said I needed.

I’m still getting the BOSH server not reachable or misconfigured message on NextCloud.

Any other ideas why Nextcloud doesn’t work with my Nethserver chat app? Have you setup chat on Nextcloud to point to your Nethserver?

Thank you.

No sorry…it’s sounds strange, it was a trivial config for me.

Of course, on the same machine.

HI @giacomo, I noticed in the documentation you linked reference to a web interface for Ejabber. It’s disabled by default. Where do I enable this?

WebAdmin: enable ejabberd built-in web interfac. Can be enabled or disabled, default is disabled

Perhaps there is a setting in there that isn’t set right compared to your setup?

Ok…digging some more into the forums I found this reference you had posted earlier @giacomo

The ejabberd web interface is disabled by default, but can be enabled:

config setprop ejabberd WebAdmin enabled
signal-event nethserver-ejabberd-save

Then you can access as, for instance, at https://ip-address-or-domain:5280/admin/

So I’ve issued that instruction on my nethserver and no errors were reported. But when I go to the admin page as instructed I get a ‘Site can’t be reached’ error. I don’t think my ejabberd is working properly on my server.

Any ideas what I can look at next or do to solve this?

Thank you.

Check the logs:

  • /var/log/messages
  • journalctl -u ejabberd

Hello @giacomo,

Oh boy…there are over 40,000 message in /var/log/messages. I’ve opened this log file and searched for text like error or fail with no success on finding a smoking gun message. I then searched for ejabberd and found lots of references but no problem messages that caught my eye.

I issued the journalctl -u ejabberd instruction then went back to my page and the message I see is

This page isn’t working

I then spun up a new nethserver (test) and the first app I put on it (after updating) was chat and again my ejabberd admin wepage says ‘This page isn’t working’.

I’m using the latest version of nethserver. Any further ideas on how I can find my error?

Sorry, we don’t have enough details to help :frowning:

But if you want, you can send me a private message with SSH access to the server.

1 Like

Thank you @giacomo, private message has been sent. Let me know if you need anything further.

Appreciate the help! :slight_smile: