Changed IP and WebTop no longer works

I changed the IP of my test server, I used the modify db command. I then connected to NS and updated gateway and dns etc, and it all seem to work ok.
The connection to my Zentyal AD seemed to be broken, so I unbinded, and updated the Accounts Provider to connect to Zentyal again (Zentyal’s IP changed as well), and it connected OK.
So, now everything on NS seems to work, and NextCloud works, but WebTop does not, it is not getting the users from Zentyal. These are all in a VM, so I was able to restore snapshots and try to do stuff in different orders, but nothing works, WebTop does not get any users from Nethserver/Zentyal.
The last attempt, I unbinded from Zentyal AD, then changed NS IP, uninstalled WebTop, updated all DNS/Gateway, etc on NS, reconnected to Zentyal using Accounts provider in NS, reinstalled WebTop, and still nothing.
Is there something in WebTop that is still looking at old IP?

Possibly, you should try to launch an event manually


You may also change the way Webtop binds to the AD when you login to Webtop as admin:

Maybe it’s better to add new domain and use the original one as template/backup. You may also try to join directly to Zentyal.

I tried changing IP on 7.4 with local AD and I also had to update the local AD to join domain again but then webtop worked.

1 Like

This has got to be it, all of the settings are changed, not sure why when I removed WebTop and reinstalled, but some setting must not have been removed on uninstall.
But, I tried this, and copied my settings exactly from old machine, and it still didn’t connect, can’t get users from directory. I will investigate more when I get a chance, not much time on the weekend.

I tried these, didn’t seem to help.
I also tried to install Roundcube, to see if I could access my mail that way, and I get the error “DATABASE ERROR: CONNECTION FAILED!” maybe that helps see what the problem is?

The ‘database error’ of roundcube is not related, it is another problem.

Roundcube use ldap only for addressbooks, not for login. You should look in /var/log/messages to see what it occurred.


I have my working system to copy from, and I have copied all values, copy and paste, and it still does not work. The only thing that is different is the password, do I copy the encrypted password, or is it the password for the Administrator account? I tried both and it does not work.

Where do I get the password from in the Domain entry?
That is definitely what is giving me the trouble. If I work on a working system, and enter my normal Administrator password, it does not work, if I ‘show password’, it looks like an encrypted password.
I do not understand why when I first installed WebTop, it entered this information manually, but now, even if I uninstall and reinstall WebTop (after changing the IP), it does not, and I have to manually enter.

There are two possibilities:

Join with machine account bind dn and bind password:

These passwords are in binary format now and may be hard to copy/paste. Try using a domain user…
You can show it with “account-provider-test dump”

Join with an AD admin user:

The password is set by you in user manager.

Just copy everything from working machine as you did already.
Then set “admin dn” to “DOMAIN\admin” instead of “DOMAIN\machine$” and the password of your domain admin user admin@yourdomain.tld.


Ok, thanks that worked.
Not sure why this was entered automatically (the domain connection) when WebTop was first installed, but does not happen now? If I was to do a fresh install, would WebTop still connect automatically, using the domain join info from NS, or has this changed, and I would have to add the connection manually?

It is intended that Webtop connects automatically. No change in that AFAIK.

1 Like

So something is very messed up from changing IP’s. I was able to connect to LDAP to get the users, but when I try and login to WebTop, all I get is a blank grey screen, with 1 white panel to the left, and the ‘new’ button which doesn’t do anything. If I install roundcube to see if I can access email that way, I get “DATABASE ERROR: CONNECTION FAILED!”

Hi @wbilger,
You can try to run the event that Provision Provider Provisioning is restored on WebTop 5:

signal-event nethserver-webtop5-update

For Roundcube you can try to delete the db and recreate it with these commands:

mysql -e "drop database roundcubemail"

nethserver-webtop5-update did not make any difference.
I ended up cloning my production server, and changed the IP on that, and everything seemed to work, so I just created a new test VM. Not sure why the original test machine would not work, but something on the machine must be different. I have a functioning test machine again.