Change mount point of Backup cache folder

backup

(EnzoC) #1

this week I had a problem with backup. saturday night nethserver do a new complete backup, but this operation filled the root partition and lock sssd and httpd-admin login.
I had this problem with zentyal several years ago.

[root@samba ~]# df -kh
Filesystem                     Size  Used Avail Use% Mounted on
/dev/mapper/centos_samba-root   50G   13G   38G  25% /
devtmpfs                        32G     0   32G   0% /dev
tmpfs                           32G     0   32G   0% /dev/shm
tmpfs                           32G  3.2G   29G  10% /run
tmpfs                           32G     0   32G   0% /sys/fs/cgroup
/dev/sda2                      497M  405M   93M  82% /boot
/dev/sda1                      200M  9.5M  191M   5% /boot/efi
/dev/mapper/centos_samba-home  201G  105G   96G  53% /home
/dev/mapper/centos_samba-srv   7.3T  920G  6.4T  13% /var/lib/nethserver/ibay
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401169
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401141
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401326
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401167
192.168.1.245:/bck-samba       2.7T  2.5T   73G  98% /mnt/backup
tmpfs                          6.3G     0  6.3G   0% /run/user/0
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401144
tmpfs                          6.3G     0  6.3G   0% /run/user/1305401162

now i have moved

[root@samba home]# mv /var/lib/nethserver/backup/ /var/lib/nethserver/home/

and stopped Backup Data

[root@samba home]# cat /et/fstab
#------------------------------------------------------------
# BE CAREFUL WHEN MODIFYING THIS FILE! It is updated automatically
# by the NethServer software. A few entries are updated during
# the template processing of the file and white space is removed,
# but otherwise changes to the file are preserved.
#------------------------------------------------------------
/dev/mapper/centos_samba-root   /       xfs     defaults,acl,user_xattr 0 0
UUID=d15de35a-7963-427d-b2d0-006def959c41       /boot   xfs     defaults        0 0
UUID=71C8-A4FB  /boot/efi       vfat    umask=0077,shortname=winnt      0 0
/dev/mapper/centos_samba-home   /home   xfs     defaults        0 0
/dev/mapper/centos_samba-swap   swap    swap    defaults        0 0
/dev/mapper/centos_samba-srv    /var/lib/nethserver/ibay        xfs     defaults        0 0
/var/lib/nethserver/ibay/home   /var/lib/nethserver/home        auto    bind,gid=46,defaults    0 0
/var/lib/nethserver/ibay/home/backup   /var/lib/nethserver/backup        auto    bind,gid=46,defaults    0 0

[root@samba home]# mount
/dev/mapper/centos_samba-root on / type xfs (rw,relatime,attr2,inode64,noquota)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
/dev/sda2 on /boot type xfs (rw,relatime,attr2,inode64,noquota)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)
/dev/mapper/centos_samba-home on /home type xfs (rw,relatime,attr2,inode64,noquota)
/dev/mapper/centos_samba-srv on /var/lib/nethserver/ibay type xfs (rw,relatime,attr2,inode64,noquota)
/dev/mapper/centos_samba-srv on /var/lib/nethserver/home type xfs (rw,relatime,attr2,inode64,noquota)
192.168.1.245:/bck-samba on /mnt/backup type nfs4 (rw,relatime,vers=4.0,rsize=524288,wsize=524288,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.241,local_lock=none,addr=192.168.1.245)

i have insert in

[root@samba home]# nano /etc/backup-data.d/custom.exclude
/var/lib/nethserver/ibay/home/backup/
/var/lib/nethserver/ibay/home/
/var/lib/nethserver/home/backup/

for the same reason I’ve already had to move the user home partition
what is the best way to change this mount point?


(Giacomo Sanchietti) #2

I didn’t get the whole post, but you can change the backup mount point using the Mount property: http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-backup-data.html

The command is:

config setprop backup-data /mnt/whatever

(EnzoC) #3

Sorry but my problem is the “Archive” not the Destination (in my case NFS)
duplicity collection-status --no-encryption --archive-dir /var/lib/nethserver/backup/duplicity/

http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-backup-data.html#duplicity

The default program used for backup is duplicity using the globbing file list feature. Encryption is disabled and duplicity cache is stored in /var/lib/nethserver/backup/duplicity/ directory. We plan to support all duplicity features in the near future.

The over 30 Gb of Duplicity Cache filled my 50Gb root partition
I backup 800 Gb of data


(Giacomo Sanchietti) #4

The only solution is changing the script, but you will loose any change after an update of nethserver-backup-data package.

If you have enough space in a local disk, you could mount a partition directly to /var/lib/nethserver/backup/duplicity/

Here is the code which needs to be changed:

I know, duplicity cache is really bad, but I don’t have a better solution right now.


(EnzoC) #5

Ok thanks