Centos first installation did not create Raid1

Hi all,

I have been playing with Nethserver in my dev environment for a few months now and am quite pleased that there is such a viable Windows AD alternative.

I have just recently installed Nethserver on two Dell Poweredge servers with an identical pair of 2 TB drives in each. Unfortunately, these came pre-installed with Win 2012 Essentials, so when I installed Nethserver, I had to go the route of installing Centos first and then running the cli commands to install Nethserver. (I will explain this further in a moment)

For this Centos installation, I selected both disks and chose automatic partitioning along with going through the process of reclaiming space and deleting all existing partitions. However, on both installs (which I later replicated on a VM in my dev environment with the same result) RAID1 was not implemented even though both disks were selected.

So, my question is, is there a way to setup RAID 1 on these drives post-install, or do I have to go back through the installation again with manual partitioning, etc. in order to implement RAID?

As a side note, I have replicated this installation scenario multiple times in multiple environments, and have found the same result that unless the drives I use are brand new, never been used drives, Nethserver will not install except by installing Centos alone first.

I even went through multiple trials of erasing the drives, formatting the drives, deleting the volume, etc. with no success on re-used HDDs. I would love some further information on this as well. Is this a bug??

Much appreciate everyone’s hard work on putting together such a viable AD alternative.



CentOS needs to be told to make RAID1, it doesn’t make it automatically.
So I think that your best option is to use the NethServer installer to use it’s automatic raid1 feature.
As you discovered, you need to give empty disks to NethServer.
To empty a disk you could use any linux live disk or NethServer itself with the following commands:

dd if=/dev/zero of=/dev/sda count=20
dd if=/dev/zero of=/dev/sdb count=20

You can run them going to a terminal at the beginning of the installation: just press CTRL+ALT+F2 at the first installation summary page (you’ll find the # prompt).
Go back to installer with CTRL+ALT+F6.

1 Like

Hi @filippo_carletti,

Awesome. I will give that a shot and report back. By any chance, is this empty disk thing referenced in the docs anywhere? I don’t remember seeing that mentioned as a requirement, but I may have missed it. It might be a good thing to add the information from your post to the docs, if it is not there already.

I really appreciate your quick response!


It is not documented, because we hope that CentOS will solve the problem. It’s a temporary problem, I don’t remember which version introduced the problem.

I attempted the work around you suggested and on the Device Selection page, it appears that the whole drive is free after running the above commands, however, when I click “Automatically configure partitioning” it still tells me I need to reclaim space because only 2008KiB is free. It still seems to see that the the disks are reused. Do you have any other suggestions?

If I reboot and then go back to the installation page, the Device Selection page also only shows 2008KiB free.

So, no matter how I tried to “empty” the disks, the Nethserver installation would not see the whole disk as free in order to perform the automatic partitioning and the checkbox for “I would like to make additional space available” takes you to another page that appears to allow you to delete partitions, but it really doesn’t…when you are back on the main menu page, it again says “failed to save storage configuration” and then “no disks selected”.

So, what I ended up doing is on the Installation Destination page, I clicked the “I will configure partitioning” and then clicked Done. At this point another page comes up that shows the current partitions on the drive(s), which because of my attempts to “empty” the drive showed a partition with the name “Unknown”. I clicked on it and then clicked the minus sign at the bottom to delete the partition, then I clicked the blue hyperlink that appeared above it that said something like “Automatically create partitions” and it configured the partitions as would be needed by the Nethserver installation. I had to manually select RAID for each partition on the “Device type” dropdown.

Then I clicked Done, and back on the main menu page I selected “Begin Installation”.

Hopefully this is a help to someone else.


1 Like