Can't reach other machines through VPN on Amazon EZ2

NS7 Amazon EC2.
I did the installation with NS7 and the openvpn-roadwarrior is running perfectly, however, I can’t reach other machines within the network through my VPN client. I have two Subnets and, I put (push “route” and push “route”) in the configuration file and everything looks normal. Has anyone been successful with this?

Can somebody help here?

@Francenildo, @m.traeumner

Hi Francenildo & Michael

I think I see a small misconfiguration here…

Two Subnets:

Pushed Route: = (<- This seems to be an error!)

The pushed route uses a mask which EXCLUDES both subnets above.
If a route is required, which covers BOTH subnets, you would need to use the following:

Pushed Route: = (<- This covers BOTH Subnets!)

Hope this helps!

My 2 cents

It wasn’t that, I solved it in another way, just typed wrong above.

1 Like

I resolved by placing this rule in / etc / shorewall / started
Ip of my internal EC2.
/ sbin / iptables -t nat -A POSTROUTING -s! -d -j SNAT --to $ ip

Could you mark this topic as solved please.

1 Like