Can't reach administration interface if squid is enabled

NethServer Version: 7RC1

I can’t reach the administration interface if I activate squid.Can somebodyelse test it please.

PS: port 980 is SSL and Safe-Port in squid.conf

Can you give more details?
In which mode is the proxy running?
Which error is shown when accessing the server manager?

The proxy is running in manual mode, and the error says: This side could not be shown.
I have only a green network.

IIRC in manual mode you have to configure the proxy settings in the clients browsers.

Yes I,ve done it, other sides like google are ok, only server-manager-site is not working. is working, but not

I can reproduce the same when the web filter is enabled; without it I can access.

In the default filter access through ip is blocked (there’s a checkbox). But seems you have hit a different problem.

1 Like

Sorry, I cannot reproduce the problem. Just to make sure I installed (on a VM) NethServer v7-rc1 from scratch, updates, first config wizard, one nic (green), installed and activated Web Proxy module (no caching) and configured client’s proxy settings. Could access the web-ui.

Did you find anything relevant on the logs?

1 Like

Thanks, this was my Problem.

1 Like

You’re welcome, thanks for the feedback. :slight_smile:

Do you think we should reverse that checkbox default?
The idea was to block by default malware that usually connects outside using IP addresses.
Often, connections to honeypots lead to being blacklisted, so we thought is was safer to block by default. The block page suggests how to reach the destination with an hostname if possible.

I think your idea to block it is the right way. "Safety first"
Perhaps you can show a squidguard error message wich says you’ve blocked sites which are called via IP-Adress instead of the message “this side could not be shown”.

The error message is there:

The access to this site is blocked.
Category in-addr
Surfing on plain IP addresses is denied from this client due to network access policies.

The following possible alternatives were found:
Please ask the webmaster of that server for the correct domainname.
Origin: 192.168.

You simply write the alternative in the browser and you’re done.

My Browser, tested with IE11 and Firefox 49 only said the following:

Die Seite kann nicht angezeigt werden.
-Vergewissern Sie sich, dass die Webadresse https://192.x.x.x:980 stimmt.
-Suchen Sie die Seite mit Ihrer Suchmaschine.
-Aktualisieren Sie die Seite in ein paar Minuten.

One strange think is that you were able to access (an IP adress) but not the same with 980 port.

I’ve tried with the host-name, in Firefox it’s no problem, in IE the Login-Page is empty

1 Like

On Windows 10 I had a similar problem in the past, were IE11 at defaults cannot access the server-manager (shows only the grey background), to get access had to uncheck compatibility view for intranet sites.

1 Like

That works for me