Can't join cluster - Error 403 Forbidden

NethServer Version: 3.16.1
Module: core

Trying to join a cluster (Leader) and just getting an error message. Tried a fresh install on the worker node with no luck.

<3> 403, message=‘Forbidden’, url=‘https://workernode.domain.com/cluster-admin/api/cluster/tasks

Systems requirements are met, same version. Running Rocky Linux 9 on both systems.

action “join-cluster” status is “validation-failed” (4) at step 00validate_cluster

Any ideas on how I could resolve that issue?

Thanks for the help!

Did you restrict the cluster-admin on the leader in the HTTP route? In that case the access is forbidden.

And there should be the same core versions on leader and worker.

Thanks so much for that reply, you are completely right. No idea why I didnt think of that, but yes I restricted access to /cluster-admin and am therefore getting the 403 Forbidden error.