Cannot access server manager from subfolder, only port

NethServer Version: v7-rc2
Module: v7

I just set up nethserver on my domain, with no issues. I even have the certs with lets encrypt working.

Anyways, I can get to the server manager via the port, say at https://domain.tld:980.

I have the nethserver-http package working, and get the test page to show up fine, so the webserver is running.

However at https://domain.tld/server-manager/ it get not found for the page. I tried a simple reverse proxy, but get a blank page.

1 Like

It works for me, I can’t reproduce the problem, I get redirected to port 980 when going to server-manager.
Do you have any error in httpd logs (access.log and error.log)?

The reverse proxy does not work with Server Manager. I think it would be a good idea to improve it after ns7 Final has been released.

Ah, okay. It’s not to much a big deal right now, hopefully the reverse proxy gets fixed in the ns7 final.

I get the following from access log whenever I try to connect to the not found page.

::1 - - [25/Nov/2016:03:50:48 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.4.16 (internal dummy connection)"

The only thing in error is this (because I have no custom index page):

[Thu Nov 24 21:27:27.785555 2016] [autoindex:error] [pid 7140] [client] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive

Not really a big problem to not get this fixed, as I can access it directly from the 980 port even when I am away from home, but I typically try to run most pages and programs on my servers in a subfolder. Less ports open, less risks with intrusions etc.