Bug when only installing Monitoring Module


I think I found a bug and I don’t know how to solve it:
If you install a clean Nethserver 6.7 and install only the Monitoring Module, you will get the problem shown and described below.

Steps to reproduce:

  1. Install a new Nethserver 6.7 with one Ethernet Adapter.
  2. Go to Software Center and Update all Packets
  3. Go to Software Center and Install “Monitoring and Inventorying” Module

“After” the installation you will see this:

If you scroll down in the Available-List, you will still see the Module:

If you try again to install, you will see the following errors poping up before the GUI changes back to the first screenshot (This error is not seen on the first try!):

When you reload the Nethserver-Page (F5), then you will get the hint do clear the yum cache instead of the first screenshot:

If you clear the yum cache and try it again, you will see the clear yum cache-Message again.

If I go to Dashboard => Applications, I don’t see any entries.

and on the Services-Tab there is also nothing about the monitoring:

I also like to attach Logs, but I don’t know which.

I reinstalled Nethserver twice always with the same result described above.

If I’m not mistaken, the error came from adagios package that is unable to solve winexe (okconfig) dependencies.
An upstream bug was opened by @davidep and seems a patch is almost ready.

1 Like

Ah, OK. If this is true, it is the same error as for the badlock-Bug?

Yes, it is. :frowning:
I hope we don’t have to wait too long, this bus is very annoying.

Is the issue solved with the pull request created 7 Days ago?

1 Like

We should take a crack at it!

Anyone checked it? The mentioned Pull Request is merged into the repository.
I don’t know how to check…

No one tried to build the RPM, I’d like to wait upstream release (otherwise we will have another RPM to maintain).

We are in a rush for the NS 7 release, maybe @davidep can try the build next week, but for now this is not a priority.