Blank screen after admin login to webtop5

Forgive the trivial question :roll_eyes: :
The system admin user has been enabled on server manager?
Is it grayed in the user list?
Can you regularly access the server manager on port 980 with this admin user?

1 Like

sorry for late reaction: birthday, flu and an extensive course kept me busy.
Yes, the admin-user is active, and I can use it for accessing the managemt-GUI with it.

Hi @rolf,
I’m sorry for the delay in my reply, but I have some news for you :wink:

I happened to find your same problem on an installation.
I realized that there were two different versions of java (1.7.0 and 1.8.0).

You can check if you have this situation in your case:

rpm -qa|grep java

If you find the two versions 1.7.0 and 1.8.0 installed you have to remove 1.8.0:

yum remove java-1.8.0*

then restart the tomcat instance so as to start it with the correct version:

systemctl restart tomcat@webtop

Doing so in my case I solved.
Check to see if this also resolves your problem.


yes, thanks, this was the solution!
(But now I have to think what on my system is depending on java 8…) :thinking:

I require java 1.8.0 for the nethserver-savapage package. I tested both, webtop and savapage, and didn’t experience problems. Is it a kind of one time error that happens under special circumstances or does Webtop have problems with java 1.8.0?

It seems that webtop has problems with the java-1.8.0 version.

What do you think @gabriele_bulfon ?
Can you find a way to run webtop 5 regularly even with java-1.8.0 version ?

Hi to all,
read this thread and read about java 1.7 and 1.8 with problems.
What is about java 1.9, version nine was released last year. Somebody tried it?

The centos repos provide openjdk 6 to 8 (1.8.0) actually.

1 Like

Ok, thanks Markus.
It’s available at the official oracle site as rpm for cent OS, so I think it don’t take a long time till it’s available at the repos too.
Here is an howto for installing it at this time (not tested)

It’s better to use packages provided by centos/epel if possible because of maintenance/stability and it’s better to use libre software like OpenJDK instead of Oracle Java so installing newest Oracle Java is really the last instance if no other solution works IMO.
Generally you are right, I installed Oracle Java 8 some time ago, it was easy and worked well on CentOS.

1 Like

The JDK1.8 issue seems not very easy to solve, we still don’t know if it’s an issue with OpenJDK, as we don’t have any issue with Oracle JDK1.8.

What I suggest is to install both 1.7 and 1.8, they will be installed under /usr/lib/jvm/jre-1.7.x and 1.8.x , then change the startup of each application to selectively use the specific JVM.


1 Like

I found an easy way to force the launch of only the webtop instance on tomcat with the version of java 1.7.0:

create this template-custom

# cat /etc/e-smith/templates-custom/etc/sysconfig/tomcat@webtop/20java17



expand-template /etc/sysconfig/tomcat@webtop
systemctl restart tomcat@webtop

So you can keep multiple versions of java installed and have no problems with WebTop 5.


Excellent work!

1 Like

Thanks to @giacomo, the change has already been included in the new update in testing:

1 Like

I updated/installed the testing version on 2 servers and one fresh VM and it works so far! On the vm I installed savapage and madsonic which require java 1.8.0 and Webtop just works. :+1: