Backup-data fails

NethServer Version: 7
Module: backup


i had backup working before with an NFS share in another datacenter.
Now that I changed this to another Server/Directory, it doesn’t backup anymore.

The new share is an NFS one too.
/mnt/zdata/Backup/Blue/ is the share

The error I get is following:
Reading globbing filelist /tmp/lOpMVTx1VN Giving up after 1 attempts. OSError: [Errno 2] No such file or directory: '/mnt/backup/blue'

I wonder where that /mnt/backup/BLUE comes from.

Edit: Here’s what ‘mount’ shows me: on /mnt/backup type nfs (rw,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,hard,nolock,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=864,mountproto=udp,local_lock=all,addr=



Okay, now I reinstalled the Backup-Module.
Is there a way to trigger the backup process manually?

Edit: never mind, found it: # backup-data

Anyway: it still doesn’t work. Why is it looking or /mnt/backup/blue? where can I change that?
The share is mounted on /mnt/backup, why doesn’t it work?

1 Like

You can do it at commandline with


Sorry don’t read, that you get it

The base path is saved here:

config getprop backup-data Mount

To the base path, the system adds the hostname of your server.

The error is probably due to duplicity, you can do this:

  • delete the backup directory from your remote location
  • delete duplicity cache: rm -rf /var/lib/nethserver/backup/duplicity/

Sure, did that. Still same error :frowning: