Authenticated proxy does not release the schedule registered internet

I have a little problem .
I created a rule to block the categories of social networking and videos during work hours and allow access to the user only after the schedule of work. however, the rule does not work and the local remain locked .
the default category I left the sites blocked forever and created other categories allowing access in particular schedule , however these schedules allowed sites remain blocked

sorry friend @Alessandronuunes , has complicated the time to give you support. I’m doing tests

@Alessandronuunes I analyzed your case.

Should have a profile that is designed for restricted access social networking, and one with access to social networks.

i.e; if normal profile of the user or group has restricted social networks, you also have to create another identical but with access to social networking profile.

in my case the profile of “gerencia” shall not have access to social networks, but in “gerenciaredes” if they have it.

try this.

Can you please provide the configuration of the default profile?

my configuration default profile

my configuration that allows access

my time setting that releases on schedule lunch

Note. I edited only css browser for the image to stay not too big

Thanks for @jgjimenezs contact. I understand it is very busy , most sincere thanks and time availability .
then in my filter setting blocks all by default for all users .
and my all_pms_lunch adjustment filter allows access to all users of pms group on social networking lunch schedule.

ie have to block access to social networks during work hours for all users and then allow access to social networks for all users at lunchtime .
when you finish the lunch break and users back to work access to social networks should be blocked again.

I think it’s some kind of priority problem inside the generated configuration file.

Use the test command and check what category blocks the navigation:


Thank @giacomo , most unfortunately could not perform this test , I’m learning to work with Linux

Hi @Alessandronuunes I have done some tests and was not satisfactory

During the morning time zone -4 I was checking another test and I will be commenting on results

or if you can, do the following test:

  • create another user can be called: test
  • create a filter where you block all
  • create a new time can be called: timetest
  • create a new profile can be called: profiletest

Logically, the time you go to create this blocked all access to the web. otherwise if you will access to web. I am right? @giacomo

1 Like

thank you @jgjimenezs
then I am performing various test and error I found was the following.

let only 3 filters
1 default filter that blocks everything not for work use
2, which allows access only social and youtube networks schedule for lunch .
3 which releases only the social and youtube night networks.
It works normal performing the lock and unlock the determined schedule.

however if you add any other filter for that group in any other schedule. the filter stops working and activate the set default

according to the image blocking filters and unlocking is working

@Alessandronuunes ok, if it works, but by placing another is all free?

another created a rule to release all access to the admin User however without success. even the User not being blocked in the group he did not access social networks

so I created a rule to release other social networks to PMS group in the morning period and the system locks the group , plus the admin User it grants access.

More doing some testing I found that only works a rule by group or User in a given schedule , if created more than one rule the does not perform blocking system

@davide_marini might help here, he’s a real expert.
@acsel10 @mansoor.tariq @Mario_Spang @cswain could you help this guy?

Hi Alessandro,

I was Reading your post and I’m having a similar issue that you describe, I want to restrict access to social networks during work time but the rules are not being applied correctly.

We have the morning timetable from 8:00 to 12:00
Lunch 12:00 to13:30
Afternoon 13:30 to 17:00

Of course during the lunch time I enabled access to social networking but the rule is not working since everybody cannot open websites like Facebook, YouTube, etc.

I Would like to see if you have found any solution that can be shared with the community.


Hello Friend.
I came to this conclusion that the nethserver can perform only one check per group or User.
then the default plan I block all
and I’m just making a release in the given schedule for that User.
ie I’m leaving the internet released on social networks just after the lunch schedule is from 11:30 to 13: 00h

In my case I was testing with v6.8 so I will test with latest NS beta v7 to see it makes any difference,


Squidguard filters all requests by parsing the configuration file from the top to the bottom: the first match wins.

I know we encountered the same problem on some of our customers, but I fear there is no simple solution using the web interface (am I right @davide_marini?).

Take a look to Squidguard configuration examples:
Then, try to hack the configuration file and when you have the correct solution post it here.
At the end, we will help you to make the modifications permanent.

1 Like