Assistance with a second Nethserver to be connected for user access to my domain Nethserver

Hello @support_team,

I have a primary Nethserver that is my office domain server and is my primary Nextcloud Server. All working well.

I’ve stood up a second Nethserver where I’ve installed a second Nextcloud for testing purposes. I wanted this second Nethserver to connect to my primary Nethserver and use the domain ID’s from my primary Nethserver. So ideally I want to be able to login to the second Nethserver and any apps on this second Nethserver I want to be able to use my accounts from my Primary Nethserver.

On this second Nethserver I’m trying to login to Nextcloud. I at first tried logging in using the local admin account and default password. But when I try I receive the following error:

The server was unable to complete your request. If this happens again, please send the technical details below to the server administrator. More details can be found in the server log.

So even using the local Nextcloud account on this second Nethserver is not working for me. I then looked in my Nethserver App log for Nextcloud and I see a long error:

{“reqId”:“9xUtg3G34xJmxqaEew9Q”,“level”:2,“time”:“2020-09-30T13:50:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“user_ldap”,“method”:"",“url”:"–",“message”:“Bind failed: 8: Strong(er) authentication required”,“userAgent”:"–",“version”:“19.0.3.1”}
{“reqId”:“9xUtg3G34xJmxqaEew9Q”,“level”:3,“time”:“2020-09-30T13:50:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“user_ldap”,“method”:"",“url”:"–",“message”:“No LDAP Connection to server ldap://nsdc-swasdomain.swaslab.local”,“userAgent”:"–",“version”:“19.0.3.1”}
{“reqId”:“9xUtg3G34xJmxqaEew9Q”,“level”:3,“time”:“2020-09-30T13:50:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“core”,“method”:"",“url”:"–",“message”:{“Exception”:“OC\ServerNotAvailableException”,“Message”:“Connection to LDAP server could not be established”,“Code”:0,“Trace”:[{“file”:"/usr/share/nextcloud/apps/user_ldap/lib/Access.php",“line”:1252,“function”:“getConnectionResource”,“class”:“OCA\User_LDAP\Connection”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/apps/user_ldap/lib/Access.php",“line”:1007,“function”:“count”,“class”:“OCA\User_LDAP\Access”,“type”:"->",“args”:["(&(&(|(objectclass=person)))(displayName=))",[“DC=swaslab,DC=local”],[“dn”],null,null]},{“file”:"/usr/share/nextcloud/apps/user_ldap/lib/User_LDAP.php",“line”:565,“function”:“countUsers”,“class”:“OCA\User_LDAP\Access”,“type”:"->",“args”:["(&(&(|(objectclass=person)))(displayName=))"]},{“file”:"/usr/share/nextcloud/apps/user_ldap/lib/User_Proxy.php",“line”:356,“function”:“countUsers”,“class”:“OCA\User_LDAP\User_LDAP”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/apps/support/lib/Service/SubscriptionService.php",“line”:128,“function”:“countUsers”,“class”:“OCA\User_LDAP\User_Proxy”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/apps/support/lib/Service/SubscriptionService.php",“line”:270,“function”:“getUserCount”,“class”:“OCA\Support\Service\SubscriptionService”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/apps/support/lib/Service/SubscriptionService.php",“line”:333,“function”:“getSubscriptionInfo”,“class”:“OCA\Support\Service\SubscriptionService”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/apps/support/lib/BackgroundJobs/CheckSubscription.php",“line”:47,“function”:“checkSubscription”,“class”:“OCA\Support\Service\SubscriptionService”,“type”:"->",“args”:[]},{“file”:"/usr/share/nextcloud/lib/private/BackgroundJob/Job.php",“line”:62,“function”:“run”,“class”:“OCA\Support\BackgroundJobs\CheckSubscription”,“type”:"->",“args”:[null]},{“file”:"/usr/share/nextcloud/lib/private/BackgroundJob/TimedJob.php",“line”:57,“function”:“execute”,“class”:“OC\BackgroundJob\Job”,“type”:"->",“args”:[{“class”:“OC\BackgroundJob\JobList”},{“class”:“OC\Log”}]},{“file”:"/usr/share/nextcloud/cron.php",“line”:126,“function”:“execute”,“class”:“OC\BackgroundJob\TimedJob”,“type”:"->",“args”:[{“class”:“OC\BackgroundJob\JobList”},{“class”:“OC\Log”}]}],“File”:"/usr/share/nextcloud/apps/user_ldap/lib/Connection.php",“Line”:212,“CustomMessage”:“Error while running background job (class: OCA\Support\BackgroundJobs\CheckSubscription, arguments: )”},“userAgent”:"–",“version”:“19.0.3.1”}

What are the steps I could implement to connect this second Nethserver to my primary Nethserver so that I may login to this second Nethserver and the apps I install on them using the ldap data from my primary Nethserver?

Any advice or pointers you can provide would be greatly appreciated.

Thank you.

@greavette

Hi Charles

Join your second NethServer to your first NethServers AD (or LDAP, if you’re using LDAP).
Account Provider -> AD -> Join

You might need a reboot, but I don’t think so on your second NethServer

Then Login to NextCloud on NetheServer2 using the local, built-in admin user with it’s default password and setup your LDAP Connector to point to your primary NethServer…

In Windows Lingo you’ld be joining a member server to an AD domain.

My 2 cents
Andy

1 Like

Hello @Andy_Wismer,

As always appreciate your help with my many questions. :slight_smile:

I’m not sure how to join my Nethserver2 to my Primary Nethserver? You mention:

Account Provider > AD > Join

Where is this done? In the GUI on my Nethserver2 or from the command line?

I can see on my Nethserver2 in Users and Groups Details of ‘Remote Active Directory’ where I’ve updated the Provider to be the same as my Nethserver Primary. Is this correct?

Thank you.

Yes, try it out…

Users should be visible in GUI… (See also old Dashboard…)

Nethserver I think needs to be connected directly (join) using the AD/LDAP screen in NethServer…

My 2 cents
Andy

1 Like

Ok, so in my Users and Groups on Nethserver2 I can see all my users from my Primary Nethserver. So I must have connected my Nethserver2 to my Primary Nethserver.

But I’m still having trouble logging into Nextcloud installed on Nethserver2. When I try to use the local admin account with the default password I get the error:

The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator.
More details can be found in the server log.

I also get the same error when I use any domain account. I must be missing some configuration setting on my Nextcloud on my Nethserver2. Any ideas?

2 Likes

I figured out my problem finally! When I connected my Nethserver2 to my domain nethserver, I did this using the old GUI (port 980) and I added in the details from my domain nethserver to my nethserver2 Accounts Provider page. I had erroneously enabled STARTTLS when I first set this up. Now that I’ve disabled STARTTLS, my nethserver2 can login to the Nextcloud I installed using my nethserver domain credentials.

Just thought I would close out this post in case someone else happens along it.

Cheers!

4 Likes