Approaching NS8 Beta 2, call for review

I will participate. My main part: ask stupid questions.:face_with_peeking_eye:

3 Likes

I just made the updates:

  1. Core update
  2. New Traefik configuration backend
  3. Update Mail modules
  4. Mail module improvements
    5 Restart NS8 (I don’t know if I had to…)

Did I miss something?

[root@ns8 ~]# podman exec redis sed -i.beta1 '/^notify-keyspace-events / d' /data/etc/redis.conf
systemctl restart redis
[root@ns8 ~]#
[root@ns8 ~]# ssh mail1@localhost
[mail1@ns8 ~]$ podman exec dovecot sh -c "doveadm index -A -q '*' ; pgrep indexer-worker | xargs -- renice"
[mail1@ns8 ~]$ exit
logout
Connection to localhost closed.
[root@ns8 ~]#

The best answer:

To you who participated to beta 2 tests:

Disable the testing flag – Modules — NS8 documentation

1 Like

I installed fresh onto debian12 and created a separate description/documentation:
NS8beta2 | Capote: my experiences and questions

1 Like

I think it’s a good question, but it’s not being asked to the right person! :wink: :laughing: :laughing: :laughing:

Fortunately, those who can give the correct answer will also read it!

Hi @alefattorini

quote=“alefattorini, post:15, topic:22156”]
Why not create a NS8_testing group?
[/quote]

Why not using Jitsi Meet (https://meet.jit.si/) once in a while for discussion ?

Michel-André

I will participate. My main part: Dumb test the thing, install things in uncoventional manner as a noob would, break things and report so its impossible to break them in the future. .:face_with_peeking_eye:

Yes, let’s go for it. What should we put on agenda?

Updated my rocky9 six months old testmachine, no errors or broken apps.
I still had to upgrade the python 3.11 stuff manually. Don’t know if it is supposed to be automatic or part of the beta2 release notes.

Edit: found a possible error: I had some http routes defined, I am no longer able to edit the rules, only the “see detail” option is enabled (edit and delete are disabled).
If I create a new rule, I can delete and edit as expected.

Yep. We’re out

Just added your name to the list above for the testing group. Is it ok for you?

Yes it’s Ok. .

Update to Beta 2 worked without problems. Christmas may come :grinning:
A big praise to the developers of NS 8.

Regards…

Uwe

1 Like

There may be a bug in the Traefik module upgrade script. Please go to Software Center click on the three-dots-menu and check the Core and Traefik version: they should be both 2.0.0

Core modules matches your list. both 2.0.0.

You can try this workaround.

  1. login as root on the system console (or via SSH)

  2. run ssh traefik1@localhost (assuming you are on the leader and the cluster has just one node)

  3. run the following commands:

    runagent bash
    mkdir manual_flags
    cd manual_flags
    
  4. Then for each route you want to make editable, create an empty file. For instance you have myroute1 and myroute2:

    touch myroute1 myroute2
    
  5. Check if the routes are now editable from the UI


For example here I have first-route, so on step 4 I do touch first-route:

Thx. The directory was there, not the files. Works now.

1 Like

Just created! @GG_jr are you willing to be the owner of the group?
https://community.nethserver.org/g/ns8_quality_group

1 Like

Hi @alefattorini ,

Thank you for the proposal, I am honored, but I am aware of my limits and I am convinced that there are other “colleagues” who are better able to do this than I am.

So please let me be a good tester and contribute as much as I can to NS8 testing and share my experience with everyone.

Greetings to all
Gabriel

1 Like