Any plans for implementing Zammad on Nethserver

(Markus Neuberger) #21

I don’t think so, they use different nginx config files and IIRC they use different ports.
But I didn’t test it yet…

(HF) #22

@mrmarkuz, is this still your objective please?


(Markus Neuberger) #23

Yes, I am going to move on when I have more time.

(Alessio Fattorini) #24

How can we help you man?

@LayLow how are you helping him?

(Markus Neuberger) #25

Thanks, I have some open projects at the moment:

  • moodle upgrade
  • keycloak
  • zammad
  • onlyoffice upgrade

But it’s just a matter of time when I can finish them…I assume to move on and have something ready this weekend.

(HF) #26

I’ll test and provide feedback if I can.

(Markus Neuberger) #27

You may use the reverse proxy module and create a virtualhost rule:

Now you should be able to browse to https://myserver.domain.local and use zammad on default HTTPS port.

Next step is to check if it’s possible to disable nginx and use apache only and allow to browse to https://NETHSERVER/zammad

(markshaz) #28

Hello did you see this maybe useful :wink:

(Markus Neuberger) #29

Thanks, that’s working! I just had to stop/disable nginx, comment out the SSLCertificate lines and set the ServerName and the Redirect.

systemctl disable nginx --now
<VirtualHost *:80>
    ServerName myserver.domain.local
    Redirect permanent / https://myserver.domain.local

<VirtualHost *:443>
    SSLEngine on
    SSLProtocol all -SSLv2 -SSLv3

#    SSLCertificateFile /etc/letsencrypt/live/
#    SSLCertificateKeyFile /etc/letsencrypt/live/
#    SSLCertificateChainFile /etc/ssl/lets-encrypt-x3-cross-signed.pem
#    SSLOpenSSLConfCmd DHParameters /etc/ssl/dhparam.pem

    # replace 'localhost' with your fqdn if you want to use zammad from remote
    ServerName myserver.domain.local

    ## don't loose time with IP address lookups
    HostnameLookups Off

    ## needed for named virtual hosts
    UseCanonicalName Off

    ## configures the footer on server-generated documents
    ServerSignature Off

    ProxyRequests Off
    ProxyPreserveHost On

      Require local

    ProxyPass /assets !
    ProxyPass /favicon.ico !
    ProxyPass /robots.txt !
    ProxyPass /ws ws://
    ProxyPass /

    # Use settings below if proxying does not work and you receive HTTP-Errror 404
    # if you use the settings below, make sure to comment out the above two options
    # This may not apply to all systems, applies to openSuse
    #ProxyPass /ws ws:// "retry=1 acque=3000 timeout=600 keepalive=On"
    #ProxyPass / "retry=1 acque=3000 timeout=600 keepalive=On"

    DocumentRoot "/opt/zammad/public"

    <Directory />
        Options FollowSymLinks
        AllowOverride None

    <Directory "/opt/zammad/public">
        Options FollowSymLinks
              Require all granted

Next step would be having zammad available at https://neth/zammad instead of a virtualhost.

(Markus Neuberger) #30

It seems not possible to have zammad at https://nethserver/zammad, at least I couldn’t make it work and I found no documentation. I tried several reverse proxy/url rewrite methods.
Zammad needs a virtualhost like mattermost.

(Markus Neuberger) #31

Work in progress:


I am actually fighting with the provided zammad package. It installs and configures zammad during yum install. If nethserver-postgresql is installed it does not work. I have to check what the zammad package does and find a workaround or maybe repackage it. This may take some more time.

(Alessio Fattorini) #32

Sounds like a great project. It would be great having a module like that for our platform

(HF) #33

@mrmarkuz, kindly asking if it works out please?

(Markus Neuberger) #34

Not much time actually, hopefully I can release something working til end of the week, I keep you updated.

(HF) #35

Thanks for your efforts!