Active Directory help joining

NethServer Version: v7
Module: Active Directory


I have installed new Nethserver v7 in order to play with AD on it. But it seems it doesn’t work.

When I try to join mydomain.local Windows refuse to join saying that domain doesn’t exist. But what is curious, I can reach shared folders and I can see domain and ping it from Windows computers.

Active Directory is set up locally, on nethserver installation.

Please, help. If more info is needed I can provide everything.

Kind regards,

Hi Jurica,
for me it looks like an DNS-problem

Some informations are interisting for us:

  • Is nethserver your DNS?
  • Can you ping the FQDN of nethserver

Also you can look at the samba.log after you tried to join the domain.

1 Like

Hi Michael,
Just to add the experience history here:

The same thing happened to me yesterday.
I tried to join a w2012 srv that was previously joined to a NS 6.8 DC but now the join did not work.
The NS 7 was configured as DNS server AD and Gateway, and I’ve added DNS records for all the hosts for the AD and NS itself…
Also in windows networking I’ve added the ip of NS as primary DNS server and the suffixes.

Still, the errors were different depending on what user i tried to join the domain with.
One of the errors was: the network path was not found or has been lost
Another was: that the domain does not exist or it could not be contacted.

nslookup resolved both the NS and AD from FQDN and both replied to ping on host.
So I somehow do not think that it was a DNS error.

When I’ll have some time I’ll try again to test.
Also a win 10 machine failed to join the domain but I given up on that more quickly.


Could you have a look at this link please.
Have you setup the registry values.

Sorry for not replying, had other issues to deal with.

I have managed to connect to domain with my computers (managed on win7, win10, osx 10.12). Nethserver is installed and has local ip AD has local ip

Another problem arised. I have user named dtc and I want to reach samba shared folder named public with no success. This is a win7 computer. I have tried several ideas:
1.) through Run command trying to reach - I can see Public share, but I cannot access it with dtc account and password.
2.) through net use command by assigning to a network drive - says it is access denied.
3.) through windows control panel by saving the credentials and then by mapping the drive - same story, access denied.

Then I tried to setup the Shared Folders under Management in NethServer.
1.) made ACL with user dtc in it - does nothing.
2.) made group named Public with dtc in it, and then make that group the owner of the Public share - nothing changed.
3.) returned to Domain Users as owner of the group - nothing also.
4.) gave permission to Guest users (read only and later rw) - dtc user still couldn’t access the shared folder, but with Guest I could.

Now I don’t know what else to do. Is there some permissions problem I need to take care first?
Also, one NOTE: every time I submit something in settings in Shared Folders in Management I got this error message, but it seems Nethserver to accept the changes: S20nethserver-ibays-set-permissions #2 (exit status 256).

Another NOTE: I managed to reach Shared folder in only one try: when I was connected with roaming profile on AD, and only when I mapped the shared folder through net use command, everything else failed.

What I need is that my user dtc can reach that damned public folder through smb.


picture of shared folders settings:

Re-installed the server again, and found out root of all misery. When creating the AD, I had to leave domain name as it is - ad.something.something. It worked like a charm after that.

1 Like