Activate admin account


(Wolfgang Höfer) #1

Hi,

I’ m new to nethserver and in the manual it is not really clear to me, how to enable the admin-account.
“set the password” - ok, but how? I think it is not meant to “import” him via csv-file. But i can’t find any command for the shell or on the root-webgui. (Perhaps i was reading not exactly enough :slight_smile: )

Thanks for hints where to search

Wolfgang

(perhaps it is special to centos? I rather come from the debian world :slight_smile: )


(Wolfgang Höfer) #2

Ok, answer to myself …

Problem solved. After Install from ISO, openldap was not installed. After installing it
with yum install nethserver-directory i was able to actiovate the admin:

lusermod admin -P secretpw

After this, login on the webinterface possible

VG


(Alessio Fattorini) #3

Unique user present on Nethaserver is root, admin could be useful just for pdc or mail server so it’s added just in this case


(Giacomo Sanchietti) #4

You can enable the admin user directly from web interface from the page “Users”.


(Wolfgang Höfer) #5

Hi,
thanks - but the page “users” didn’t exist on my installation. I had to install the nethserver-directory at first. After that there was the user page available.


(Stefano) #6

how did you install NS?

you don’t need admin user to access web UI.

moreover, acting via CLI and usermod command is not the recommended way… did you read the documentation?


(Wolfgang Höfer) #7

Hi,

yes - in parts. While reading “accessing the servermanager” i stumbled across the sentence

“If the directory module is installed, and the admin user has been enabled, you can use it to access the web interface with same privileges as root user. See Admin account.”

I thought, that the directory-module is installed by default und the “enable the admin” should be possible in the standard-installation. My fault.

“after installing the directory module, activate the admin” would have been clearer to me. Might be a problem for me as non nativ speaker :smile:

… My install was from the nethserver-iso