A brief introduction

NethServer Version: Zentyal 4.2, looking for best replacement

Hi, I’m the IT manager for a growing bio-food and cosmetics company in Belgium. Currently we are using Zentyal 4.2 for our email and some file sharing. On seperate (virtual) servers we also have and Alfresco and an Openerp running on ubuntu servers.
The Zentyal user database has become inconsistent because of many upgrades (been running zentyal since ebox) and the last upgrade from 3.2 to 4.2 removed many features and broke samba.
Now I want to move to nethserver, not only would it replace the zentyal virtual server, but the owncloud module could phase out alfresco, which was rather overkill for us anyways.
Openerp could stay in a box, or possibly even move to the NS itself, all in due time.

First I tried the latest/greatest NS7 rc but I could not access the samba shares as a user or group only as a guest. And since not all windows are professional yet joining a domain is not yet a working solution for us.
So now I’m getting ready to set it all up on NS 6.8.


Hi @indra and welcome to the NethServer Community.
I know what you have been through. I am in a transition of saying farewell to Zentyal (3.2) and adopt NethServer. As soon the final version is released I will start migrating my 3 Zentyal servers to NethServer.
If you can not join the domain with all your pc’s because they are not Professional versions, NethServer 6.8 is a safe bet. However, NS7 will come with a pack of new options. So it might be worth it to have a bit of patience and go for NS7 anyway. (remember NS7 didn’t reach final version so bugs still exist. We are working hard to splash them)
I am in Belgium too. Maybe we can join forces and start spreading the word in Belgium (and the Netherlands).
And of course, if you need help in any way, just yell: we are here to help.


Hi @robb and thank you. Yes joining forces is what we Belgians are all about ;-).
No seriously, wherever possible and feasible I always love to contribute what I can. (as little as it may be, says the small belgian in me :-D). Ok enough Belgian jokes O:-)

On the server, base system and modules are installed and now I’m in the process of migrating users and groups, without the data. I’ve got my users listed in a csv and import them first with the instructions found here for the automated email account creation.
After I create the groups and add the users to the groups using this script. This seems to work pretty OK although I had a strange error listed in messages log many times during both imports.

Nov 24 18:09:02 nethserver esmith::event[465]: WARNING in /etc/e-smith/templates//etc/postfix/aliases/40accounts: Use of uninitialized value in string eq at /usr/share/perl5/vendor_perl/NethServer/MailServer.pm line 83.

And when I tried to remove a group I got an error in the webui, and the groups was removed on the webui, but was left in the database, marked deleted. I manually removed them with the db accounts delete group command. That worked, all well so far, imapsync is next one up, next week.

Ps Removed all users and groups and re-added them, found out that when I create the groups manually instead of letting the second script create them, groups can be removed from webui without error.

1 Like

This is probably harmless, I hope that @davidep could confirm.

1 Like

It should be safe. I’ll tell you tomorrow.

I want to clarify that this is a regression bug that has been fixed. The fixed package is in testing and is going to be released soon. Do you want to check it out?

As said above, NTLM authentication will be back soon. I guess Win Home supports it. We must say NethServer 7 shared folders are accessible from Windows Home ed.

I wouldn’t go with ns6 for new installations once ns7 Final is released!

Hi Davide,

when will it be?



That’s great news, on Monday when I’m back in the office I’ll reinstall NS 7 rc2.
Are the user import scripts I used on 6.8 also available (and safe) on NS 7?

Sure, do I understand correctly I can reactivate NTLM authentication on NS 7 and allow Windows home users access to group shares with these 2 commands :

Thanks for all the help, more on Monday :slight_smile:

1 Like

The NethServer 7 Final release is still not scheduled. We’re working on rc3, and we hope CentOS 7.3 is going to be released soon. We could build our ISO on it, and would be a nice thing because it reduces the pending RPM updates after a fresh installation.

No, not at the moment. But if you want to test them, I can fix them next week! Would you want to try?

As said by @filippo_carletti, that WARNING can be ignored. I also say, if you go with ns7 you won’t see it anymore!

Sure, I’ll be back in the office on monday, first l’ll get NS7 on a virtualbox to see if I can get the NTLM authentication going. If thats working I’ll reinstall NS7 on the test server and see if the import scripts work.
It’s gonna be an exciting week :smiley:


Just did a quick test with NS7 rc2 in a virtual box. Unattended install, updated, installed nethserver-file-server and nethserver-dc. Setup dc, created user, group, share, added it all up and ran fix on CLI [quote]
alternatives --set libwbclient.so.0.12-64 /usr/lib64/samba/wbclient/libwbclient.so.0.12
systemctl restart smb
I can access the share with “domain\user” for the login :+1: but not as “user”, even when i set the correct workgroup.

1 Like

Can you post a screenshot of the login dialog?

1 Like

This morning I reinstalled NS7 rc2 on the test server (a decommissioned Proliant ML350) and setup everything but the user accounts. (Eagerly) Waiting for import script fix :innocent:

1 Like

I hope I’ll get time for it tomorrow morning

EDIT: you can find them here

1 Like